Carte audio RME HDSP et Windows 7 x64

Veuillez noter que cet article pourrait probablement s’appliquer pour Windows Vista x64, mais je ne l’ai pas tester.

Intro

Pour faire ça simple RME est une compagnie qui fait d’excellente carte audio. Je ne parle pas d’ici de carte audio de gameux boutonneux, mais de cartes pour les professionnels. Ces cartes servent à faire du montage, tout comme elle peuvent simplement servir d’interface pour rouler des shows. Leurs cartes utilisent des pilotes ASIO, se qui permet également pour les programmeurs de logiciels de communiquer avec celles-ci via la ASIO SDK.

Récemment j’ai dût faire l’installation de 8 de ses cartes dans des systèmes roulant sur Windows 7 x64. J’ai entre autre installé des HDSP 9632 ainsi que des HDSP AES-32.

Problématique

Le CD de pilotes venant avec cette carte ne possède pas les pilotes pour Windows 7 x64. En fait, il date de 2008 si on en croit l’indication imprimé sur le dessus (les pilotes de Vista ne sont probablement même pas dessus). En allant sur le site de RME-Audio, on y retrouve les pilotes pour Windows 7 x64. Ces derniers cependant, requiert la dernière version du firmware sur la carte.

Hors, lorsqu’on utilise l’utilitaire de mise à jour du firmware, il nous est impossible de détecter la carte audio, puisque les pilotes ne n’y sont pas installé. Donc on a un système Windows 7, avec des pilotes Windows 7 qu’on ne peut pas installer, puisque la carte ne possède pas le dernier firmware, puis on ne peut pas mettre à jour le firmware, car l’utilitaire de mise à jour du firmware ne détecte pas la carte sans que les pilotes y soient installés.

Un peu ridicule, n’est-ce pas?

De plus, dans le fichier readme.txt de l’utilitaire de mise à jour du firmware, on nous dit que le nouveau firmware est « backward compatible » avec les vieux pilotes. Ce qui ne s’avère pas du tout le cas, croyez-moi!

Solution

  1. Installer la carte dans un système roulant Windows XP x86
  2. Installer les pilotes de WinXP x86 provenant du CD (les derniers pilotes sur le site Internet requiert également le dernier firmware…)
  3. Redémarrer
  4. Faire la mise à jour du firmware grâce à l’utilitaire de mise à jour
  5. Redémarrer
  6. Installer les derniers pilotes de WinXP x86 afin de vérifier que la carte fonctionne bien (les pilotes du CD ne fonctionnent plus avec le nouveau firmware…)
  7. Redémarrer et au démarrage vérifiez que la carte est bien détectée
  8. Éteindre le système
  9. Installer la carte dans votre système Windows 7 x64
  10. Installer les pilotes Windows 7 x64
  11. Redémarrer et vérifiez que la carte est bien détectée

 

Commentaires

  1. Bonsoir,

    Merci déjà pour ces indications: c’est exactement la procédure que je vais avoir à faire… quoique.
    Je m’explique:
    Je suis passé depuis peu de WinXP x86 à Win7 x64.
    Mon problème, c’est que j’ai déjà tenté par 2 fois de le mettre à jour le firmware sous XP, il ya quelques années. Et « Failed » à tous les coups, et retour chez RME pour reprogrammer la cardbus, en prime.
    Ma carte est donc toujours en « Revision 11 », (je sais, ça date) et j’éprouve des sueurs froides rien qu’à l’idée de retenter l’expérience.
    Mais maintenant que je n’ai plus le choix…

    Est-il normal d’avoir à insister autant sur la procédure d’update?

    Merci encore.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *